`

PAT 1011. World Cup Betting (20)

    博客分类:
  • PAT
阅读更多

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98

#include<stdio.h>
int main(){
	double w, t, l;
	double maxProfit = 1;
	int i;
	for(i = 0; i < 3; i++){
		scanf("%lf%lf%lf", &w,&t,&l);
		if(w > t && w >l)
		{
			printf("W ");
			maxProfit *= w;
		}
		else if(t>l){
			printf("T ");
			maxProfit *= t;
		}
		else {
			printf("L ");
			maxProfit *= l;
		}
	}
	printf("%.2f\n",(maxProfit*0.65-1)*2);
	//printf("%.2f\n",(maxProfit*0.65-1)*2 +0.005);
    return 0;
}

 NOTES:

感觉这道题目有点问题,例子是错的,

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics